[sssForm]

Security Advisory

TLS/SSL - CVE-2016-10213
Published: Thursday, July 12th, 2018
Last Update: Thursday, July 12th, 2018
Summary

On June 10, 2016, A10 published a blog post entitled CVE-2016-0270 GCM nonce vulnerability [1] discussing an issue with how certain devices generate the nonce for AES-GCM. With resolution for CVE identifier assignment complications at the time for CVE-2016-0270 [2], this issue was addressed for the following vulnerabilities and as described further in this document.

Item # Vulnerability ID Score Source Score Summary
1 CVE-2016-10213 CVSS 3.0 5.6 Med AES-GCM Nonce Vulnerability [3]

 

It was determined that the TLS/SSL data-plane in certain A10 ACOS release families were potentially exposed to exploit due to use randomly generated, AES GCM Nonce values.

Affected Releases

The table below indicates releases of ACOS exposed to these vulnerabilities and ACOS releases that address them. ACOS release families not indicated below are unaffected by these vulnerabilities.

Customers using potentially exposed releases can update ACOS to the indicated resolved release or subsequent updates. If the table does not list a corresponding resolved or unaffected release, then no release update is currently available or anticipated.

Releases Affected Releases Resolved or Unaffected
4.1.0 – 4.1.0-P1 4.1.0-P2
4.0.0 – 4.0.3-P1 4.0.3-P2
2.7.2 – 2.7.2-P7 2.7.2-P8
Workarounds and Mitigations

None.

Software Updates

Software updates that address these vulnerabilities are or will be published at the following URL:
https://www.a10networks.com/support/axseries/software-downloads

Vulnerability Details

Software updates that address these vulnerabilities are or will be published at the following URL:
https://www.a10networks.com/support/axseries/software-downloads

Vulnerability ID Vulnerability Description
CVE-2016-10213

A10 AX1030 and possibly other devices with software before 2.7.2-P8 uses random GCM nonce generations, which makes it easier for remote attackers to obtain the authentication key and spoof data by leveraging a reused nonce in a session and a "forbidden attack," a similar issue to CVE-2016-0270.

Related Links

The following table shares brief descriptions for the vulnerabilities addressed in this document.

Ref # General Link
[1] A10 Blog - CVE-2016-0270 GCM nonce vulnerability
[2] NIST NVD, CVE-2016-0270
[3] NIST NVD, CVE-2016-10213
[4] Nonce-Disrespecting Adversaries: Practical
Acknowledgements

A10 would like to thank Hanno Böck who had discovered issues with how devices generate the nonce for AES-GCM and subsequently published a paper, Nonce-Disrespecting Adversaries: Practical Forgery Attacks on GCM in TLS [4], on the topic.

Modification History
Revision Date Description
1.0 Saturday, August 22nd, 1970

Initial Publication


© Copyright 2018 A10 Networks, Inc. All Rights Reserved.

This document is provided on an "AS IS" basis and does not imply any kind of guarantee or warranty, including the warranties of merchantability, non-infringement or fitness for a particular use. Your use of the information in this document or materials linked from this document is at your own risk. A10 Networks, Inc. reserves the right to change or update the information in this document at any time.